@Patreonteam: UI / UXP glitches: *Bugs* and issues to fix


I keep moaning about Patreon’s website being glitchy, so I think I am morally compelled to put butter by the fish (I know, I know … that doesn’t work in English, but “talk Turkey” or “get to the point” just doesn’t cut it. Note the “by”, which is intentional :smiley: )

  • Featured Tags: Can not be set in “Edit your page”, but in “Edit your page / POSTS”. Documentation is outdated on that one
  • Featured Tags: Are case sensitive. Who came up with such an idea?! There should be auto-completion on that line in the editor to avoid typos and casos (does the term “casos” exist yet? Meaning “case-sensitivity-errors”)
  • Headline tag H5 does not work (gets converted into HTML entities)
  • Headline tag H4 is way too big (compare to H3)
  • Patreon does not display correctly on some mobile devices (example: built in IE on Windows Phone 8.1)

Feel free to add to the list, maybe we can also remove points once they get resolved.


1 Like

I did hope that others would add issues … but well, here’s another pain I am just going through:
For several minutes (according to the clock on the wall about 14 minutes by now) I am trying to find an IN DEPTH list of income versus expenses in my account. Details seem to be sprayed all over the place, from account settings to dashboard and back.
Now - I found a list that claims “amount pledged at end of month” - in my examples this shows these numbers:
11 + 36 + 23 + 24 + 30 + 26
… which sums up to 150.
I found another page that lists some payouts for pledges I sent to other creators. For the same time span this was:
4,76 + 4,76 + 2,38 + 0,00
… which sums up to 11,90.
I found yet ANOTHER page that lists “pledges processed”, this shows:
23 + 24 + 30
… which sums up to 77.

Note the “slight” difference to 150 from above.

I found YET ANOTHER page that lists “patreon fees and processing fees”. That lists, as the (seemingly) FINAL output to my account:
20,11 + 20,96 + 26,30
… which sums up to 67,37

Now I can substract 11,90 from 67,37, which gives me a final OUTPUT of 55,47. From 150 I am down to 55,47. And it took me 22 minutes to get to this number, including putting together this comment.

Patreon, your UXP is horrible. You cannot seriously expect someone who is trying to get some money through Patreon (which she/he will obviously have to declare as an income, giving CLEAR and PRECISE lists of billed/payed components to THE STATE) to waste that much clicks and time on getting basic account information collected! This has to be in ONE PAGE with EXACT declarations of income/expenses.
PLEASE have ONE professional account page that lists all fiscal transfers.
Please have that NOW. I am doing weekly accounting.

Marc Albrecht

Don’t worry, I am not going to moan about the bug/glitch that has cost me a whole month’s Patreon income again.
Sorry, the “community guideline” about “not signing your post” is a bad idea. My username is “malbrecht”, but my NAME is not. It is a question of politeness and respect to use your NAME when communicating with human beings.

I’ve been noticing that when I reply to someone or comment on their Patreon that once I’ve used up the entire visible field I cannot see what I am typing. I’ve tried scrolling and arrowing down, but the minute I start typing my text hops back up to the top and I can’t see what I’m typing again. I’m using Firefox and don’t know if this is happening in other browsers.

1 Like

Hi, “Lochy”,

I had that phenomenon once or twice but could not reproduce it - it did go away for me when I resized the window. If you are using a desktop browser where you can try that, it’s worth a go (forcing the browser to rebuild the window in which you are typing). On a tablet/phone that probably won’t work, though.
Not sure if that is a Patreon bug, the thing I experienced definitely looked more like a browser thing.


1 Like

Thanks! I think someone may have told me that once and forgot.

Search function on Patreon is … let’s say “strange”. I just felt like I could spend some money on creators, so I did a quick type-in of something I would like to support.
I typed in “animation”.
What I got back was a spinning “wait-circle”. I let that spin for 7 minutes, then closed the site, as there obviously aren’t any creators doing animation that want my (financial) support on Patreon.

Suggestion: Make the search function return usable results.
Hint: That includes the ability to actually FIND creators with the search function. How often have I tried to find someone who is only using some nickname/username publicly - but doesn’t use the same as her patreon URL.

Suggestion: Make the search function search internally in given names and family names, too. I know this is a privacy risk, so give creators the choice to make their names searchable (although maybe not displayable).

Hey Marc,

This reply may be too late to reach you, but just in case you’re still around, I wanted to let you know that giving you WAY better information about your finances is going to be a priority for me in 2018, after we get PRM into a good place. We’re definitely behind in improving the tools you all rely on to run your business, and that’s my entire focus here at Patreon.

It’s going to be slow going as we take on each of these things, but I at least want you to know that I hear you, I know these things are painful for many creators, and this is high on my list.



Hrm, I’m still havin’ this issue and it continues even if I resize the window. Any other workarounds on this?

Hmm, I’ll take a look at this and log a bug if I can reproduce!

@Lochy I just want to confirm that what you’re experiencing is what I’m seeing. Any chance you could do a screen recording for me? If not, no worries. Here’s what I’m seeing happening:

  • You can type quite a bit before anything weird happens
  • At some point, as you keep typing and are moved to a new line, the field fails to scroll

I’m not seeing the behavior where scrolling / arrowing down jumps back to the top when you stop typing again, so I might be missing a step. Let me know if that’s what you’re experiencing, or if I’m missing something! :slight_smile:

1 Like

I’m sorry, I can’t do a recording, but basically you have it. Once I’ve filled in the visible field it doesn’t scroll down as I am typing so that I can see what I’m typing beyond that point. If I scroll down myself as soon as I start typing the entire block of text pops back up to the top so again I can’t see what I’m typing.

I’m also dealing with a problem today that I’ve been having off and on for a while now. I go to add a link in a post and nothing happens when I confirm the link. In the past I just keep adding it over and over until it takes, but that’s stating to get old especially when I need to add multiple links in a post.

Thanks so much for gettin’ back about that with me, @erin

I just found another little issue. I went to change one of my featured tags, but cannot scroll down when selecting as the bottom part of the menu is under the footer. My workaround is to add the tag I want to feature to more posts to move it up in the menu, make it featured, and then go back and take the tag off of the inappropriate posts. It’s a pain in the backside, but it’s workable.

The other thing is that the featured tags are not showing as links. They ARE links, but the cursor doesn’t change when you roll over them to indicate they are. To me this is a more pressing issue because it affects patron/follower navigation.

1 Like