Vimeo videos not working

Hey everyone,
I had issues with Vimeo videos on my Patreon page and I see many others are having similar issues here, so I’ll just round up what I am experiencing.
@ Patreon support : please take care of this and keep us posted, I feel this issue is not being considered enough.

  1. “Connect to Vimeo” button does not work for me (the button displaied when you post a “video” content)… I tested in Google Chrome and Brave Browser. It opens a popup asking me to allow Vimeo to access Patron, I click “allow” and then the page is just blank. Tested several times.

  2. As far as I see, Vimeo playlists are not supported. Tried to paste a Vimeo playlist link in the “video url”, not working.


Vimeo integration is currently being overhauled. For now, you can copy/paste the video link from Vimeo to ‘Add url’ choice in video post. This will embed the video. Also you should remember to set as an embed-allowed domain for the video to make it viewable via Patreon.

Thanks, I tried that, but in some cases the video gets displayed as a grey rectangle until you click on it.
I tried several times, and only in one case Patreon was able to pull the video thumbnail and show that instead of the grey rectangle.
I think there are some issues here, YouTube videos have no problems.

If the video is just recently uploaded, it may take some time before Vimeo starts providing its embed - causing the video preview (ie the still frame before clicking play etc) not being available.

In my case it happens even with videos that have been uploaded months ago…

What happens when you retry embedding such a problematic video in a new post?

Same thing, always a grey rectangle with a “play” icon in the middle. Patreon can not generate a thumbnail for Vimeo.
Only in one case it generated the corrected thumbnail, out of about 20 videos I have tried to embed.

Is in allowed list for embeds at your Vimeo account?

The video works normally if you click on the play icon, is just the thumbnail that is not visible.

I have opened a ticket about this, will post here their reply.

1 Like

After checking the videos privacy settings I found the culprit.

These Vimeo videos where set as “hide from Vimeo”.

Even if they were set to be embedded on, the “hide from Vimeo” option was causing issues.

If I set them as “anyone can see” or “people with private link can see” then the thumbnail is retrieved correctly.

1 Like

Vimeo was working just fine when I first integrated it, but now I have this exact same problem.

The authentication page shows up as blank.

It’s also strange, because I’ve already authenticated it before and could just drag and drop the videos until today.

I’m having this issue as well currently

Can you forward your creator pages at Patreon to me via DM? Also, let me know which browser+device you are using.

Also having this issue. Has anyone heard how to resolve?

same problems, on both laptop and PC, firefox and edge

@Peter_Ferriero @kalcia Does this situation still persist for you?

I’m having this problem, regardless of what I set the Vimeo permission to. It’s an absolute nightmare. I managed to get two videos to have the proper thumbnail but it took hours of loading and re-uploading. I am either getting an awful thumbnail plucked from the middle of the video or the grey box with the play symbol in. Once click onto this, the proper video with proper thumbnail appears, but the initial image ruins the branding of my page and makes it look ugly. I’m using a Firefox browser but had the same issue using the browser on my phone.